Best Practices

Professionalism and expertise does not lies in how good you are at a software or the quality in your portfolio, these soft skills such as organization and thoughtfulness factors into a good motion designer.

File Organization & Management

Good housekeeping rules make collaboration a seamless and enjoyable experience.

Why is important?

  1. Team-level people do not need spend time looking for the right comps or assets, unified system of how to make sense of project files and their elements, avoid confusion

  2. Personal-level curation - never fret where your files are , easy access for reel editing or upload, avoid duplicates and reduce storage space usage, cleanliness

  3. Desmond-level: I hate unorganized people

Since my journey in digital media in 2010, the most efficient and optimal file folder structure I have used is the one from WarnerMedia Studios. Working there, we mostly just access just 2 folders: projects and library. Projects contains folders of different projects with a standardized naming convention, and library is a folder filled with assets such as textures, stock photos, 3D models, and so on. I used to separate project folders based on "personal" and "professional" but then I realized it was better to just combine them.

root
projects
project_1 // use "standard" file folder structure below
project_2
...
lib
branding
portfolio

Folder Structures templates

If you are on a mac, you can copy any of the snippets below to create a folder structure on your desktop. Alternatively, you can download zip files

HOME โ€” Database

v2
v1
v2
cd ~/desktop
mkdir home
cd home
โ€‹
mkdir -p data/{00_passport_photo,01_id,02_employment,03_studies,04_immigration,05_tax,06_housing,07_insurance,receipt}
mkdir -p portfolio/{_final_delivery,footage/{2020,2019,2018,2017},lib/{01_logos,02_photography,03_footage,04_movs,05_textures,06_3DModels,07_audio,08_fonts},working_file}
mkdir -p 'projects'/DATE_PROJECTNAME
mkdir -p branding/{_final_delivery,lib/{01_photo,02_featured,03_accolades,04_references},working_files}
mkdir -p 'ฮฉ UNSORTED'
v1
cd ~/desktop
mkdir HOME
cd HOME
โ€‹
mkdir -p OUT
mkdir -p DATA/{ID,PASSPORT,IMMIGRATION,PROFILE_PHOTOS,SIGNATURE,TAX,HOUSING,INSURANCE}
mkdir -p PORTFOLIO
mkdir -p 'PROJECT โ€” PRO'
mkdir -p 'PROJECT โ€” PERSONAL'/DATE_PROJECTNAME
mkdir -p 'ฮฉ UNSORTED'

For Projects

small
standard
shaw
small
cd ~/desktop
mkdir project_folder_smallForm
cd project_folder_smallForm
โ€‹
mkdir -p 01_Out
mkdir -p 02_Dailies
mkdir -p 03_Workfiles/AEPs
mkdir -p 04_Assets
mkdir -p ฮฉ_SANDBOX
standard
cd ~/desktop
mkdir project_DVFX
cd project_DVFX
โ€‹
mkdir -p '_final_delivery'
mkdir -p working_files
mkdir -p dailies
mkdir -p 'lib'/{_from_client,_seq,01_logos,02_photography,03_footage,04_movs,05_textures,06_3DModels,07_audio,08_fonts}
shaw
cd ~/desktop
mkdir project_folder
cd project_folder
โ€‹
mkdir -p ELEMENTS/{3D,AUDIO,FONTS,FOOTAGE,RASTER,VECTOR}
mkdir -p DELIVERABLES
mkdir -p PRESENTATION/{00_PDF,01_INDESIGN,02_STYLEFRAMES,03_WIP,04_BTS}
mkdir -p PROJECTS/{AEP,C4D}
mkdir -p REFERENCE
mkdir -p RENDERS

File naming conventions

Naming Projects

As someone who makes tutorials, I use project code to differentiate them.

//nosleepcreative
ms - masterstudies
exp - expression
gen - generative
collab - collaboration
cs - carousel
โ€‹
// personal
fl - freelance

For one-off projects, I still abbreviate them into project code such as "comotion" to "cm"

Quick access with Alfredโ€‹

The major benefit of having a consistent file structure and naming convention is how you can access your files just by using the keyboard in a second rather than clicking through a series of folder to get to it. I use a macOs and I make use of this free app called Alfred which is basically a faster and customizable version of Spotlight (the search bar).

AE Organization & management

Essentially, you want to use the same principles as above: having a consistent folder structure, responsibly naming your files, and reducing project size.

Folder Structures

Setting up preferences to auto-load AEP template

Under Preferences > New Project > Choose Project Template > Select AEP to use for startup

โ€‹

After Effects Output Modules (AOM)

Rule of thumb:
prores 422HQ for delivery,
4444+alpha for video that needs alpha,
LT if storage space is limited,
โ€‹
mp4: high quality 2 pass encoding 50mbps, max render quality

How to save Render Settings(ars) and Output Modules (aom)

If you want to save a render-settings template for use on another system

  • Click the Save All button in the Render Settings Templates dialog box before you close it

  • or, reopen the dialog box later by choosing Edit > Templates > Render Settings).

  • Save the file in an appropriate location on your hard disk, such as in the After Effects application folder.

  • All the currently loaded render settings are saved in a file with the .ars extension.

  • Then, copy this file to the disk of the other system. When you start After Effects on that system, choose Edit > Templates > Render Settings, click the Load button, and select the new .ars file to load the settings you saved.

โ€‹Sourceโ€‹

How to load AOM files

Have a item in the render queue > Output Module > Make Template > Load > Select AOM file

How to deliver files

When sending files over to your teammates or any other personnel, please make use of the Reduce Project feature in AE. This will remove any used assets or compositions

Optimization & Efficiency

Workspaces

Animation Preset

Why: to avoid recreating the same things over and over again, it is a good practice to save and curate your commonly used effects and their settings into animation preset. This way you can avoid rewriting expressions, setting keyframes, or applying combination of effects.

As a motion designer, I highly recommend everyone to build their own library of animation presets that will serve as their bag of tricks. Not sure animation presets but rigs or templates AEPs as well.

How to save animation presets

Select the properties / property groups that you want > animation menu > Save as Animation Preset

How to save Render Settings(ars) and Output Modules (aom)

If you want to save a render-settings template for use on another system

  • Cick the Save All button in the Render Settings Templates dialog box before you close it

  • or, reopen the dialog box later by choosing Edit > Templates > Render Settings).

  • Save the file in an appropriate location on your hard disk, such as in the After Effects application folder.

  • All the currently loaded render settings are saved in a file with the .ars extension.

  • Then, copy this file to the disk of the other system. When you start After Effects on that system, choose Edit > Templates > Render Settings, click the Load button, and select the new .ars file to load the settings you saved.

โ€‹Sourceโ€‹

โ€‹

Extensions

ScriptUIs

Project scale

Skills: using proxies, internal file marking, and render setting.

Editing can become such a pain when things aren't optimized as files get bigger and longer. Some file sizes that are 2-3Gb only actually need to be under 100 Mb. If you set up your files properly so that someone else can use it, your team will love you for it.

Readings

Communication

When working with my peers, here are specifications I always provide for their final delivery.

specs
resolution - 1920x1080
fps
duration
codec - prores 422 hq or prores 4444+alpha
โ€‹
Animation
shading done via rendering/AE post
specific properities - rot x -90 to 90
โ€‹
project file delivery
reduce project

Shortcuts that you should know

Basics

Command

Shortcut

Quit

Cmd + Q

Close composition

Cmd + W

New project

Cmd+Alt+N

New Folder

โŒฅ+โ‡ง+โŒ˜+N

New Composition

Cmd+N

New Adjustment Layer

Cmd + Alt + Y

New solid

Cmd+Y

New Null Layer

Cmd + Alt +Shift + Y

โ€‹

โ€‹

Timeline

โ€‹

โ€‹

Show animated properties

U

Show modified properties

UU

Show Expressions

EE

Replace Footage

Cmd + Option + H

Adjust Kerning

Option (Alt) + Left/ Right Arrow keys

Adjust Tracking

Option (Alt) + Up/Down Arrow keys

Trim comp to in & out

Cmd+Shift +X

Trim layer inPoint to CTI

cmd+ [

Trim layer inPoint to CTI

cmd+ ]

Render

Cmd + Shift + /

Render Queue

Opt + Cmd + 0

New project

Opt + Cmd + N

Collapse layer properties - Shift + ~

โ€‹

โ€‹